postfix: 421 SMTP command timeout.
3758
4
F1!
FreeBSD 4.9 + postfix 2.0.15
Перестала уходить почта до всяких там mail.ru и иже с ними.
Не трогал ничего! Оно само:улыб:
Лог полон 421 SMTP command timeout. Closing connection и timed out while sending message body

Сделал sysctl
net.inet.tcp.path_mtu_discovery=0
net.inet.tcp.rfc1323=0

Ноль на массу..
Канал вроде нормальный
во вскяком случае до гейта
# ping -c 100 -s 16384 -S внешний_ip gateway_ip
100 packets transmitted, 100 packets received, 0% packet loss
round-trip min/avg/max/stddev = 31.012/35.322/57.549/4.083 ms

До mxs.mail.ru пакеты больше килобайта не ходят
# ping -c 200 -s 1024 -S внешний_ip mxs.mail.ru.
--- mxs.mail.ru ping statistics ---
200 packets transmitted, 197 packets received, 1% packet loss
round-trip min/avg/max/stddev = 74.732/105.494/203.267/27.082 ms

labaton-gw# ping -c 200 -s 1024 -S Внешний_ip mail.ngs.ru
--- mail.ngs.ru ping statistics ---
200 packets transmitted, 193 packets received, 3% packet loss
round-trip min/avg/max/stddev = 29.516/121.247/311.784/49.429 ms

Стандартным пакетом
# ping -c 200 -S внешний_ip mail.ngs.ru
--- mail.ngs.ru ping statistics ---
200 packets transmitted, 197 packets received, 1% packet loss
round-trip min/avg/max/stddev = 7.817/86.632/475.666/63.538 ms

Но доставка почты до нгс-а происходит
# tail -f /var/log/maillog | grep ngs.ru
Nov 28 10:26:12 labaton-gw postfix/pipe[34680]: CE16DAC21: to=, rel
ay=forwarder, delay=63, status=sent (server.cis.ru)
Nov 28 10:26:58 server postfix/pipe[34837]: D6340AC23: to=, rel
ay=genocide, delay=108, status=sent (server.cis.ru)
Nov 28 10:27:43 server postfix/pipe[34995]: DE991AC24: to=, rel
ay=spamfilter, delay=91, status=sent (server.cis.ru)
Nov 28 10:27:51 server postfix/smtp[35018]: setting up TLS connection to mx.
ngs.ru
Nov 28 10:28:33 postfix/smtp[35018]: AFA34AC21: to=, rel
ay=mx.ngs.ru[83.222.14.50], delay=95, status=sent (250 66398275 message accepted
for delivery)

Может таки дело в канале?
Full
Гугль рулит!
Вот что нарыл

>>This smells like a classic MTU problem. Try to decrease MTU size on your
>>outgoing network interface.
> Thanks for your suggestion.
>
> I lowered MTU on Postfix Box to 1450...
>
> Still timing out on the body..
Try 1000.

И они таки правы!
Оно помогло, дело таки в канале.
Full
теоретически, еще могло помочь разрешение в полной мере icmp, который в частности занимается согласованием размера mtu. но работает это не всегда (кто-нибудь по дороге еще может порезать). поэтому практичное решение уменьшить mtu вручную, действительно.
hidden
ну так по теории я первым делом и добавлял полное разрешение icmp, но оно не помогло. Явно где-то дальше у прова туннель криво mtu обрабатывает.

А где ты раньше был?:улыб:Я тут целую неделю мучаюсь, куда ломиться не знаю, а ты сидишь и молчишь:улыб:
Full
Не ругай его - он в отпуске был:улыб:

Кстати, из-за подобной кривой настройки у провов сами страдаем по чёрному... На одном почтовом серваке вообще опытным путём пришли к MTU=450. И хоть ты тресни...