1С спецодежда.... где исправить начисление износа?
4285
5
Помогите, пожалуйста!
Спецодежда в 1С начинает списываться со следующего месяца, нужно сделать чтобы списание начиналось с текущего...
что тут надо исправить или дописать в "Начислении амортизации"?

В самом документе "Передача спецоджеды в эксплуатацию" есть тольк условие:
формируются проводки: сумма списывается, если списаие производися в момент выдачи одежды в эксплуатацию..., а линейное списание - через документ "Начисление амортизации".
Может где-то еще есть ссылка, чтобы с/одежда начинала списываться с текущего месяца?

// ПогашениеСтоимостиСпецматериалов()
//
// Параметры:
// Нет.
//
// Вызывается из формул элементов диалога:
// Нет.
//
// Описание:
// Здесь описывается процедура.
//
Процедура ПогашениеСтоимостиСпецматериалов()
Если СпецодеждаСпецоснастка = 1 Тогда
БухИт10 = СоздатьОбъект("БухгалтерскиеИтоги");
БухИт10.ИспользоватьСубконто(ВидыСубконто.Материалы);
БухИт10.ИспользоватьСубконто(ВидыСубконто.НазначенияИспользования);
БухИт10.ИспользоватьСубконто();
БухИт10.ВключатьСубсчета(-1,);
БухИт10.ВыполнитьЗапрос(НачМесяца(ДатаДок), , "10.11",,,,, "С");
БухИт10.ВыбратьСчета();
Пока БухИт10.ПолучитьСчет() = 1 Цикл
БухИт10.ВыбратьСубконто(ВидыСубконто.Материалы);
Пока БухИт10.ПолучитьСубконто(ВидыСубконто.Материалы) = 1 Цикл
Материал = БухИт10.Субконто(ВидыСубконто.Материалы);
БухИт10.ВыбратьСубконто(ВидыСубконто.НазначенияИспользования);
Пока БухИт10.ПолучитьСубконто(ВидыСубконто.НазначенияИспользования) = 1 Цикл
НазначениеИспользования = БухИт10.Субконто(ВидыСубконто.НазначенияИспользования);
Если НазначениеИспользования.СпособПогашенияСтоимости = Перечисление.СпособПогашенияСтоимости.ПогашатьСтоимостьВМоментПередачиВПроизводство Тогда
Продолжить;
КонецЕсли;
НезаполненныйРеквизит = "";
ДатаВводаВЭксплуатацию = НазначениеИспользования.ДатаВводаВЭксплуатацию;
СпособПогашенияСтоимости = НазначениеИспользования.СпособПогашенияСтоимости;
СрокПолезногоИспользования = НазначениеИспользования.СрокПолезногоИспользования;
Если ПустоеЗначение(НазначениеИспользования) = 1 Тогда
Продолжить;
ИначеЕсли ПустоеЗначение(ДатаВводаВЭксплуатацию) = 1 Тогда
НезаполненныйРеквизит = "Дата ввода в эксплуатацию";
ИначеЕсли ПустоеЗначение(СпособПогашенияСтоимости) = 1 Тогда
НезаполненныйРеквизит = "Способ погашения стоимости";
ИначеЕсли ПустоеЗначение(СрокПолезногоИспользования) = 1 Тогда
НезаполненныйРеквизит = "Срок полезного использования \ предполагаемый объем выпуска продукции";
ИначеЕсли ПустоеЗначение(НазначениеИспользования.СчетЗатрат) = 1 Тогда
НезаполненныйРеквизит = "Счет отнесения погашенной стоимости";
КонецЕсли;
Если ПустоеЗначение(НезаполненныйРеквизит) = 0 Тогда
ТекстСообщения = "Для материала " + Материал + " в назначении использования "
+ НазначениеИспользования + " не заполнен реквизит """ + НезаполненныйРеквизит + """. Стоимость погашения материала для этого назначения использования не будет рассчитана.";
глСообщениеПроведения(ТекстСообщения, ТекущийДокумент(), -1,, НазначениеИспользования.ТекущийЭлемент());
Продолжить;
КонецЕсли;

//Списывать начинаем с начала следующего месяца,
// т.к. единица учета - месяц, то списывать необходимо
// начиная с полного месяца.

//Пытался я задокументировать эти три строчки, не помогает:хммм:

Если КонМесяца(ДатаВводаВЭксплуатацию) >= КонМесяца(ДатаДок) Тогда
Продолжить;
КонецЕсли;

БухИт10.ВыбратьСубконто(3);
Пока БухИт10.ПолучитьСубконто(3) = 1 Цикл
ПодразделениеСотрудник = БухИт10.Субконто(3);

НепогашеннаяСтоимость = БухИт.СКД(БухИт10.Счет, "С",, БухИт10.Субконто(1), БухИт10.Субконто(2), БухИт10.Субконто(3));
Если НепогашеннаяСтоимость <= 0 Тогда // погашено
Продолжить;
КонецЕсли;

Если БухИт10.Счет.Код = "10.11.1" Тогда // спецодежда
ПервоначальнаяСтоимость = БухИт.СКД("МЦ.02", "С",, БухИт10.Субконто(1), БухИт10.Субконто(2), БухИт10.Субконто(3));
Иначе
ПервоначальнаяСтоимость = БухИт.СКД("МЦ.03", "С",, БухИт10.Субконто(1), БухИт10.Субконто(2), БухИт10.Субконто(3));
КонецЕсли;

Если ПервоначальнаяСтоимость <= 0 Тогда
Продолжить;
КонецЕсли;

СуммаПогашения = 0;

Если СпособПогашенияСтоимости = Перечисление.СпособПогашенияСтоимости.ПропорциональноОбъемуПродукцииРабот Тогда
ОбщийОбъемПродукции = СрокПолезногоИспользования;
ОбъемПродукцииЗаМесяц = НазначениеИспользования.ФактическийОбъемПродукцииРаботЗаМесяц.Получить(КонМесяца(ДатаДок));

СуммаПогашения = Окр((ПервоначальнаяСтоимость / ОбщийОбъемПродукции) * ОбъемПродукцииЗаМесяц, 2);
СуммаПогашения = Мин(СуммаПогашения, НепогашеннаяСтоимость);
ИначеЕсли СпособПогашенияСтоимости = Перечисление.СпособПогашенияСтоимости.Линейный Тогда
СуммаПогашения = Окр(ПервоначальнаяСтоимость / СрокПолезногоИспользования, 2);
СуммаПогашения = Мин(СуммаПогашения, НепогашеннаяСтоимость); // берем меньшую сумму
КонецЕсли;

Если СуммаПогашения > 0 Тогда
Операция.НоваяПроводка();
Операция.НомерЖурнала = "МТ";
Если БухИт10.Счет.Код = "10.11.1" Тогда // спецодежда
Операция.СодержаниеПроводки = "Погашение стоимости спецодежды";
Иначе // спецоснастка
Операция.СодержаниеПроводки = "Погашение стоимости спецоснастки";
КонецЕсли;
Операция.ПервичныйДокумент = глПредставлениеПервичногоДокумента(Контекст);
Операция.Дебет.Счет = НазначениеИспользования.СчетЗатрат;
Операция.Дебет.Субконто(1, НазначениеИспользования.Субконто1);
Операция.Дебет.Субконто(2, НазначениеИспользования.Субконто2);
Операция.Дебет.Субконто(3, НазначениеИспользования.Субконто3);
Операция.Кредит.Счет = БухИт10.Счет;
Операция.Кредит.Субконто(1, БухИт10.Субконто(1));
Операция.Кредит.Субконто(2, БухИт10.Субконто(2));
Операция.Кредит.Субконто(3, БухИт10.Субконто(3));
Операция.Сумма = СуммаПогашения;
СуммаОперации = СуммаОперации + Операция.Сумма;
КонецЕсли;
КонецЦикла;
КонецЦикла;
КонецЦикла;
КонецЦикла;
КонецЕсли;

КонецПроцедуры // ПогашениеСтоимостиСпецматериалов()
Sky
:ха-ха!: :ха-ха!: :ха-ха!:
Это вообще-то денег стоит :ухмылка:
Sky
Отладчик Вам поможет. Запустите, посмотрите, что за что отвечает. Ну и потом подправите.
А вообще могу сказать: Если 1С это написало так. То для начало подумать. А может это правильно.
craxx
за ответить: есть ссылка там-то, смотри там-то - это стоит денег? насмешили теперь уже Вы меня....
Ваше право или ответить или молча прочитать...

текс выложил, чтобы про номер релиза и т.д. не спрашивали...
АФМ
"...Если 1С это написало так. То для начало подумать. А может это правильно."

1С - это не Минфин...., и программа 1С в части некоторых разделов учета "кривая".
Нормативно начало списания с/одежды нигде не утверждено, поэтому предприятие обязано самостоятельно утвердить в учетной политике как происходит списание...

1С пошли по пути наименьшего сопротивления: установили списание подобно основным средствам (по ОСам в ПБУ 6 прописано, что амортизация начисляется со следующего месяца).
т.е. нет в разделе 1С "Учетная полиика" выбора как списывать спецодежду.
Sky
Пытался я задокументировать эти три строчки, не помогает


Видимо как-то плохо пытались. )) должно работать.

но сходу никто верный ответ вам не даст, ибо как сказано выше надо смотреть через отладчик. к тому же, на первый взгляд, придеться её кое-что подправить, чтобы умножть на коэф. "работы" в месяце (ведь он не полный).